Domanda:
BlasNotFoundError durante l'installazione di Scipy tramite pip
ohblahitsme
2012-08-26 23:56:08 UTC
view on stackexchange narkive permalink

Sto provando a installare Scipy in un ambiente virtuale tramite pip e ricevo un errore che dice numpy.distutils.system_info.BlasNotFoundError Non l'ho mai incontrato prima e l'ho installato numpy da pip, quindi dovrebbe aver installato tutto correttamente. Ho cercato sul sito di Blas e sono riuscito a trovare solo una versione per FORTRAN e non so se è quello che mi serve. Qualsiasi aiuto sarebbe apprezzato!

Sì, BLAS è scritto in FORTRAN. Hai bisogno della libreria condivisa.
Ho scaricato il tar con i file FORTRAn. Come lo installo come libreria condivisa? O sto cercando qualcos'altro?
Quale distro stai usando? Probabilmente è nei repository tbh.
Una risposta:
#1
+11
ohblahitsme
2012-08-27 01:42:57 UTC
view on stackexchange narkive permalink

Se sei su Raspbian, installa il pacchetto libblas-dev tramite apt. Dovrebbe funzionare bene dopo.

Inoltre ho dovuto installare `gfortran`,` libopenblas-base` e ​​`libatlas-base-dev` per farlo funzionare.


Questa domanda e risposta è stata tradotta automaticamente dalla lingua inglese. Il contenuto originale è disponibile su stackexchange, che ringraziamo per la licenza cc by-sa 3.0 con cui è distribuito.
Loading...